Zsh Mailing List Archive
Messages sorted by:
Reverse Date,
Date,
Thread,
Author
PATCH: OpenBSD sys{clean,merge,patch,upgrade} completion
- X-seq: zsh-workers 49731
- From: Matthew Martin <phy1729@xxxxxxxxx>
- To: zsh-workers@xxxxxxx
- Subject: PATCH: OpenBSD sys{clean,merge,patch,upgrade} completion
- Date: Mon, 31 Jan 2022 22:11:10 -0600
- Archived-at: <https://zsh.org/workers/49731>
- List-id: <zsh-workers.zsh.org>
- Mail-followup-to: zsh-workers@xxxxxxx
OpenBSD has a number of small sys* commands that lack completion (though
sysclean is in ports).
diff --git a/Completion/BSD/Command/_sysclean b/Completion/BSD/Command/_sysclean
new file mode 100644
index 000000000..755861644
--- /dev/null
+++ b/Completion/BSD/Command/_sysclean
@@ -0,0 +1,6 @@
+#compdef sysclean
+
+_arguments -s : \
+ '(-p)-a[include filenames used by installed packages]' \
+ '-i[include ignored filenames]' \
+ '(-a)-p[output package names that are using obsolete files]'
diff --git a/Completion/BSD/Command/_sysmerge b/Completion/BSD/Command/_sysmerge
new file mode 100644
index 000000000..00ee18299
--- /dev/null
+++ b/Completion/BSD/Command/_sysmerge
@@ -0,0 +1,6 @@
+#compdef sysmerge
+
+_arguments -s : \
+ '-b[run non-interactively]' \
+ '-d[do not take any automatic action]' \
+ '-p[only compare configuration of packages]'
diff --git a/Completion/BSD/Command/_syspatch b/Completion/BSD/Command/_syspatch
new file mode 100644
index 000000000..850636d09
--- /dev/null
+++ b/Completion/BSD/Command/_syspatch
@@ -0,0 +1,7 @@
+#compdef syspatch
+
+_arguments \
+ '( -l -R -r)-c[list available patches]' \
+ '(-c -R -r)-l[list installed patches]' \
+ '(-c -l -r)-R[revert all patches]' \
+ '(-c -l -R )-r[revert the most recently installed patch]'
diff --git a/Completion/BSD/Command/_sysupgrade b/Completion/BSD/Command/_sysupgrade
new file mode 100644
index 000000000..b1144b0d5
--- /dev/null
+++ b/Completion/BSD/Command/_sysupgrade
@@ -0,0 +1,9 @@
+#compdef sysupgrade
+
+_arguments -s -S -A '-*' : \
+ '-f[force an already applied upgrade]' \
+ '-k[keep the downloaded files]' \
+ '-n[do not reboot]' \
+ '(-s)-r[upgrade to the next release]' \
+ '(-r)-s[upgrade to a snapshot]' \
+ ':installurl:'
Messages sorted by:
Reverse Date,
Date,
Thread,
Author